Map tools tab
  • 01 Sep 2022
  • 14 Minutes to read
  • Dark
    Light

Map tools tab

  • Dark
    Light

UserInterfaceassetsimagesimage29.gif

The Map Tools tab is available from the main ribbon of Flood Modeller's interface. The buttons found here are grouped into 7 tool groups which allow you to perform various functions, such as:

  • Adding GIS data to your project
  • Generating new GIS data to assist with model building
  • Loading / processing results from 1D and 2D models
  • Adding bookmarks to highlight parts of the map view
  • Adding notes to provide further information in your model
  • Geo-processing of GIS data

Each of the 7 tool groups are described in turn below.

GIS Data Tool Group

The buttons in the GIS Data section allow you to either add existing GIS files to the Map View or create a range of new files which can be added and saved to the project.

UserInterfaceassetsimagesimage003.pngIf you would like to add GIS data to your map, this can be done by clicking the ‘Add GIS Data’ button. This will open a new window prompting you to browse to, and select, the file (or files) that you wish to add. Note the drop-down menu on the bottom right of this window which lists all supported file types that can be selected. Once you have selected your file (or files), click ‘Open’ and the new layer (layers) will be added to the map view as well as be listed in the ‘Layers’ window of the interface (lower left corner).
UserInterfaceassetsimagesimage30.gifIf you would like to create a new GIS layer, this can be done by navigating to the ‘New’ button of the GIS Data Tool Group. Clicking this will activate a drop down menu with the following layer options to choose from: Shapefile or WMS Layer.

If you select the Shapefile option, the following window will appear:
UserInterfaceassetsimagesimage005.png

The above window allows you to select the type of shapefile you would like to create, depending on the purpose it is going to serve. Once you have chosen the type of shapefile that you would like to create, you need to specify a name and location for saving it.

If you select to Create a WMS Layer, the create WMS layer tool will then be displayed in a new window as shown below:

UserInterfaceassetsimagesimage009.jpg

A WMS layer is a layer of maps located on a WMS server. A WMS, or Web Map Service, is a protocol for providing georeferenced map images via the Internet. These map images are generated by a map server using data from a GIS database.

If this is the first time you are accessing this function, it will have no servers specified initially. If a WMS server link has already been established, it will be listed.

The command buttons available on this window are defined as follows:

  • Validate – Flood Modeller checks it can successfully connect to the selected WMS Server and reports back the available layers for you to review prior to adding them to your view
  • Add - Prompts you to define a new link to a WMS Server
  • Edit - Enables an existing WMS Server link to be edited
  • Delete - Removes an existing WMS Server link
  • Save - Saves your defined list of WMS Server links as an XML file to be recalled in a subsequent Flood Modeller session. Note that if the file is named 'WMSservers.xml' it will be automatically loaded into the WMS server links table.
  • Load - Enables you to load a previously defined list of WMS server links for you to then select one to load as a new layer in your view.
  • OK - After validating a selected WMS Server link this button proceeds to load the associated data as a new layer in your view. You will be prompted to provide a filename for your new layer (which is given a '.wms' file extension)
  • Close - Closes the WMS server window without adding any data to your view.

Generators Tool Group

The Generators Tool Group allows you to add features such as spill, reservoir or cross sections into your project.
UserInterfaceassetsimagesimage010.pngSpill Units provide pathways for flow to traverse from in-bank onto the floodplain. These are effectively modelled as weirs running parallel to a river, and are defined by a set of ground levels and corresponding chainages (between adjacent river nodes). Flood Modeller provides the facility to automatically extract this information from a specified ground grid. This requires the following to be defined:

  • Ground grid data – this will be interrogated to obtain the vertical elevations along each specified spill line. The grid should be an ASCII format grid (.asc).
  • One or more spill lines – this is a line alongside the modelled watercourse across which an overflow will be modelled. It may be represented by an existing polyline shapefile defined elsewhere or it can be a new polyline shapefile that you 'draw' yourself.

Once you have specified your ground grid and spill line shapefile, click on the Spill Generator tool – a new window will then displayed, as shown below:

UserInterfaceassetsimagesimage011.png

You can review the spill data calculated by this tool either in long section chart format or in IED format within a text viewer. You can then decide whether to proceed to save the spill data to an IED file.

UserInterfaceassetsimagesimage012.png


The reservoir generator tool converts shapefile polygons into reservoir units by defining a series of constant height 'contours' within each polygon. By calculating the area confined by each contour, Flood Modeller can build a set of depth against surface area data pairs that a reservoir unit requires.


In order for this to be carried out, the following must be defined:

  1. Ground data.
  2. Reservoir polygons. If a shapefile of reservoir polygons already exists then this can be loaded into the viewport. Alternatively, a new shapefile can be defined.

After creating or loading a reservoir outline shapefile, click on the Reservoir button from the Map Tools tab. The Reservoir Generator window will then be displayed, as shown below:

UserInterfaceassetsimagesimage013.png



UserInterfaceassetsimagesimage014.pngThe Cross Section Generator button opens the river section builder, within which you must specify the necessary information to define your cross sections. These are as follows:


  • Polyline shapefile loaded into Layers window that represents your river centre line - this must be selected in the Layers window before the cross section tool is run.
  • Cross section separation along the river centre line, which can be defined either by a specified number of equidistant sections or by a maximum distance between sections. Alternatively, you can request a cross section at every point along the centre line.
  • Length of cross section – you must specify the distances from the centre to the left and right banks individually.
  • 1D node label for each cross section. This can be taken from an existing field in the centre line dbf file or you can specify a common name and Flood Modeller will automatically increment each cross section by assigning a number (starting at '001')
  • Common roughness value to be assigned to each cross section. This can be edited in individual sections later if required.

UserInterfaceassetsimagesimage015.png

Toolbox Tool Group

The Toolbox tool group contains range of commands which relate to modelling. The buttons here allow you to carry out functions such as creating TIN surfaces, exporting shapefiles to KML, plotting cross-sections and a number of other options relating to grid data processing. You can also access the Modelling Toolbox and Flood Viewer tool from this section.
UserInterfaceassetsimagesimage016.pngThe Modelling Toolbox groups together all key functions which relate to modelling, providing an easy to use, single point of access to all of these tools. The toolbox can be accessed by clicking on the Modelling Toolbox button in the Map Tools tab, or by selecting the ‘Toolbox’ button from the group of buttons at the bottom right corner of your user interface. The toolbox will open as a new window on the right side of your map viewport.

UserInterfaceassetsimagesimage017.png

UserInterfaceassetsimagesimage018.pngThe TIN Creator tool is designed to generate and edit interpolated triangular network surfaces. These are then used to transform 1D hydraulic model results into 2D flood extent surfaces.

The TIN Creator triangulates any complex surface containing ESRI shapefiles (polygons, polylines (curves) and points). In addition some shapes within the input data can be specified as 'holes'. The triangulation process will then go around these areas leaving them blank. Holes are useful to define areas in a model that you want to keep 'dry' when creating a flood water surface from model results.

UserInterfaceassetsimagesimage019.pngThe Export to Google Earth button converts a shapefile to kml format and provides the option to upload the file to Google Earth after the conversion is complete. Selected attributes data can also be assigned to the kml file to provide a colour scale, e.g. water depth data.

UserInterfaceassetsimagesimage020.pngFlood Viewer is an interactive flood visualisation tool which aims to provide rapid access to historic/predictive flood extent mapping in an emergency situation (e.g. control room). The tool allows you to relate maps of different flood extents to a single gauge level, and you can control the extent output by selecting the desired gauge level. The Flood Viewer tool runs within your web browser and can be used from a USB stick or over the web, and therefore there is no requirement for expensive GIS software and no issues with IT compatibility. In addition to basic GIS viewing functions it incorporates a slider, allowing you to move seamlessly between different flooding scenarios (e.g. return period events, time)

UserInterfaceassetsimagesimage022.jpg

UserInterfaceassetsimagesimage023.png


The Plot Section button allows you to view an animated sequence in a cross section plot. To do this, you must first load your 2D results into Flood Modeller. In addition, load the ground level data used to define your model.

If you are using a shapefile to define your cross section then a window will be displayed listing all polyline type shapefiles in your map view. Select the required file and click the OK button.

A new window will be displayed containing an empty x-y chart, as shown below. To the left of the chart the compatible datasets available for plotting are listed.

UserInterfaceassetsimagesimage024.png

Flood Modeller can be used to manipulate raster datasets (either loaded into the viewport or external files).

The following functions are available for affecting grid data:

UserInterfaceassetsimagesimage025.png

  • Grid Calculator - Flood Modeller provides the Grid Calculator tool to perform basic arithmetic on grid data. This can be the manipulation of data within a single grid or the combining of multiple grid datasets to create a new grid output. This feature can be utilised to:
    • Convert the units within a grid
    • Find the difference between two grids, e.g. differences in flood extent
    • Add grids together, e.g. add ground grid data to water depths to create a water level grid
  • Surface Calculator - this is compatible with binary (flt), ASCII (asc) and ESRI grid formats. However, it is not compatible with TUFLOW 2D modelling grid outputs. This will be addressed in future to enable calculation of flood hazard grids, i.e. cross products of vector and scalar time series data.
  • Resize - Enables you to resize a grid, i.e. create a new grid that is a subset of the source grid. This is useful to improve performance if only a small part of a large grid is being used. The cell size must remain the same as the original so the only user settings are either revised numbers of rows and columns or revised grid coordinates (for lower left corner). These are set in the new window that is displayed when this option is selected. Note the grid to be resized must be first selected in the Layers window before this tool is accessed.
  • Resample - This function enables the generation of a grid with a different cell size to the source grid. The source grid can be one already loaded in the Layers window or an external grid that you select. The tool is displayed in a new window. You must select an output filename and location as well as the cell size for the new grid. The cell size of the specified source grid is displayed as a guide. If a larger cell size is selected, than Flood Modeller will calculate an average value based on the source cells contained within each output cell. If a smaller cell size is selected then all output cells within a source cell will take the same value (i.e. that of the source cell).
  • Superimpose - Enables you to superimpose elevations from one grid onto another, e.g. change levels over part of a grid by superimposing more recent data. The two grids specified for this operation (base grid and additional layer) can be different extents and resolutions. Either a new grid can be generated as an output or the base grid data can be overwritten. The extent of the output grid can be the same as the base grid or can be the combined extent of both input grids. The required input data are defined in a new window.
  • Stamps SHP features - This functionality enables you to superimpose the attributes of a shapefile onto a grid e.g. the z values or other data stored in the shapefile. A new panel is displayed on selecting this tool which prompts you to select an appropriate grid and shapefile, and select the attribute to be displayed on the new grid.

Bookmarks Tool Group

To help you in navigating around a large model, the bookmark facility allows you to mark units of reference or particular importance. The bookmarks can be given two priorities (high or normal), are colour-coded and can be easily navigated using the F9 key.
UserInterfaceassetsimagesimage026.pngThe Quick Add button allows you to quickly add current extent to the bookmark.

UserInterfaceassetsimagesimage027.pngThe Quick Add button allows you to quickly delete the last bookmark.

UserInterfaceassetsimagesimage028.pngSave/Load Bookmarks buttons allow to save bookmarks in a new file or load bookmarks from an existing file respectively.

Notes Tool Group
Flood Modeller provides the option to add labels or images to a grid, map, or any other suitable layer. There are three types of labels that you can add:

  1. The text label editor can be launched by selecting the Add Text Label button, UserInterfaceassetsimagesimage029.png. This then launches the map label editor, which can be seen in the figure below.UserInterfaceassetsimagesimage030.png
  2. An image can be added to the viewport using the image label editor. When selecting the button Add Image Label, UserInterfaceassetsimagesimage031.png, from the Map Tools tab, you will be prompted to find the location of an appropriate image.

  3. The final type of label which can be created is a link label, UserInterfaceassetsimagesimage032.png. This provides a text label in the viewport, which when clicked offers further details in a text box, and a link to an external file.

UserInterfaceassetsimagesimage033.pngThe final three buttons within the Notes Tool Group are ‘Clear All’ – which allows you to remove all labels; ‘Save’ – which saves the labels to the disk; and ‘Load’ – which loads labels that have been saved to the disk.

Map View Tool Group

This group of options provides range of tools for viewing the data.
UserInterfaceassetsimagesimage034.pngThe Flood Modeller 3D Viewer is a separate application linked to the main Flood Modeller interface which enables you to view your data in a three dimensional viewport.
The 3D Viewer is accessed from the main toolbar by clicking on the 3D Viewer icon, shown above. This will prompt you to select which files currently loaded in the Layers window should be also loaded into the 3D Viewer. In addition to preselecting layers in the main Flood Modeller interface to load into the 3D Viewer, the 3D Viewer toolbar includes an Add Layer menu. This enables additional layers to be added after you have accessed the separate 3D Viewer interface.
UserInterfaceassetsimagesimage035.pngIf you wish to navigate to a specific location on a map or grid, then the Go To X,Y button can be used. This allows you to enter the coordinates of an exact location, and the viewport will move to centre on that location. The level of zoom will remain the same.

UserInterfaceassetsimagesimage036.pngIf the exact location of a grid or map is known in x and y coordinates, the Set Extent tool can be used to manually set the position of the viewport. The Set Extent tool can be found under the View tab in the top right of the MAPPER window. On launching the set extent tool, the panel as shown below will be launched. You can then enter the extreme value of the top, bottom, left and right of the extent required to be launched in the viewport.

UserInterfaceassetsimagesimage038.png

UserInterfaceassetsimagesimage037.pngIn addition to the layer properties window, if you right click on the Flood Modeller map view the displayed menu includes a map properties item. If this is selected a new window is displayed that contains overall map properties, i.e. properties that are independent of all loaded layers. An example of this window is shown in the figure below:

The map properties window provides the following functions:

  • Change shapefile drawing properties, e.g. line and shape colours (as you are drawing - the finished shape colours are set in individual layer properties).
  • Zoom and pan sensitivity to mouse movements
  • Viewport rotation - map is rotated, e.g. to obtain optimum orientation when creating a display for a report.

After settings have been defined, click the Apply button to implement them. Note that shapefile drawing functions will apply to the next new shapefile created / edited in the viewport (current files may not display the changes).

Geoprocessing Tool Group

UserInterfaceassetsimagesimage039.png
The Geoprocessing tool group contains options for performing basic GIS tasks for analysis and/or management of the geographic data within your project. The following buttons are available:

  • Buffer: creates a buffer shapefile around a specified shapefile layer.
  • Clip: uses the outside polygon boundary of the clip coverage to cookie-cut features and attributes from the input coverage.
  • Merge: combines selected features of the same layer into one feature. The features must be from either a line or a polygon layer.
  • Intersect: creates a new shapefile from the common areas or edges of any two selected layers of the same geometry type. The new intersected feature is created using the settings specified in the chosen feature template.
  • Union: computes the geometric union of two shapefile layers.
  • Dissolve: Creates a new shapefile by merging adjacent polygons, lines, or regions that have the same value for a specified field.




Was this article helpful?

What's Next