Results Tab

1D Results Tool Group

Four main types of graphs are available to view the results of a 1D simulation. These are:

There are a number of methods of producing graphical output from the results of 1D simulations, depending on which part of the user interface is active.

Cross Section

To plot a cross section:

  1. Select the required unit in the network chart/table.

  2. Click the Cross Section button in the 1D Results tool group. Alternatively, you can right click on the selected unit and choose Cross Section from the pop-up menu options.

  3. Select the type of variable to be plotted and the required time.

  4. Click Plot to display the cross section graph.

You can add additional series (for example to compare the maximum stage from two simulations) by selecting Add Series from the graph pop-up menu.

Long Section Plot

To plot a long section:

  1. Select the nodes which you want to be included in the plot.

  2. Click the right mouse button while within the selected area and choose Long section from the menu options. Alternatively, you can click the Long Section Plot button in the 1D Results tool group.

  3. Select the type of variable to be plotted and time range.

  4. Click Plot to display the long section graph.

You can add additional series (for example stage from another simulation) by right clicking on the graph and selecting Add Series. Any appropriate tabulated data can be superimposed on the long section by using the 'Custom data' option. The custom data should be contained in a file with the extension .cus, which must be in the format detailed in Additional Datafile Formats.

Time Series

To produce time series plots (e.g. flow against time):

  1. Select the required unit in the network chart/table.

  2. Click the Time Series button in the 1D Results tool group. Alternatively, you can right click on the selected unit and choose Time Series from the pop-up menu options.

  3. Select the variable (e.g. Flow) and select Plot

Once the graph is displayed other lines (e.g. other nodes, other variables and other models) can be added by selecting Add Series from the graphs context (pop-up) menu. Also, any appropriate ASCII tabulated data may be superimposed on time series plots by using the 'Calibration' option. The data must be contained in a file with the extension .cal and this file must be in the format detailed in Calibration Datafile. Note that any of the model variables can be used (not just stage or flow).

XY Series

The XY plot option allows the user to plot any output variable against another. Of particular interest is the flow-stage (Q-H) relationship. To display an XY plot:

  1. Select the required unit in the network chart.

  2. Select XY series from the pop-up (right-click) menu (or alternatively click on the XY series toolbar icon or use Ctrl-Q).

  3. Select the type of variables to be plotted ("Variable" will be plotted against the y (vertical) axis and "2nd variable" will be plotted against the x (horizontal) axis. The defaults are Stage (y) and Flow (x).

  4. Select the time range from which the results are to be obtained and displayed.

  5. Click Plot to display the long section graph

Note: Only one relationship is allowed to be displayed per plot, and the "Add series" option is disabled.

Flood Mapping

The 1D Flood Map button allows you to post process 1D results data to generate flood extent maps. These can be single snapshots within a time series, maximum flood extents or animated sequences of flooding. You can view flood extents overlaid on other GIS data, e.g. DEMs, aerial photos or Ordnance Survey tiles. The data generated by Flood Modeller can be exported for use in other applications, e.g. Google Earth and other GIS Software, or as images in reports

 

Tabular CSV

Options

The Tabular CSV output utility is accessed via the Tabular CSV button in the 1D Results tool group. It features a subset of the options available in the Tabular Output option, with the difference that tabulated output is supplied in Comma Separated Variable (CSV) format for easy access and further manipulation in spreadsheet packages, such as Microsoft Excel. Additionally, there is an option to write results for all nodes at a specified time in 'initial conditions' format for use as initial conditions for subsequent runs. The output options are:

  1. Simulation Results - output at selected time intervals at all or selected nodes.

  2. Maxima and minima of all or a single variable at all or selected nodes.

  3. Extract new boundary conditions.

  4. Initial Conditions output.

By default, the output for options 1 and 2 is written to a results file with extension '.csv'. Boundary conditions (option 3) are written to a file with extension '.bdy' and Initial Conditions (option 4) are written to a file with extension '.zzs'. After generating the results, the program will attempt to display the results by opening the file with the default viewers registered for the relevant extension. For instance, csv files will often be associated with Microsoft Excel.

For any option, the user may select any number of nodes from the model for output, with Select All and Remove All buttons being available. Node selections may be saved using the Save button on the Node Selection tab, and subsequently reloaded via the Retrieve button.

Output Parameters

Simulation Results

The default option is to produce results for Stage in "One Column Per Node" format. This means that all selected nodes will be displayed across the output page, with one row for each output time. A warning message will display if more than 255 nodes are selected since the maximum capacity of Excel is 256 columns. In this case, data for all nodes will still be written to the csv file, although it will not load fully into Excel. Any of the six Flood Modeller output variables (Stage, Flow, Velocity, Froude Number, Unit Mode and Unit State) may be output, or all six may be chosen. In the case of the latter, output for each variable is written beneath the whole section for that of the previous variable.

If "One Column Per Node" output is deselected, data for each node will appear beneath all of that from the previous one, again with one output timestep per row. One or all six output variables may be chosen for output; if the latter is selected, one column of output will be displayed for each variable.

Maxima and minima

The outputs for this option which is produced in CSV format are the maximum and minimum values of the selected variable at the node. Single variables and any number of nodes may also be selected.

Extract Boundary option

Option 4 is used to extract new boundary conditions from the results for subsequent 1D model runs. The tabular processor prompts the user to specify the node label for which the boundary conditions are required. Three types of boundary can be derived:

For flow-time data you can specify that flow values are averaged over the printout interval, to give, for example, mean daily flows. The new boundary data is written to a file with the name in the form nodelabel.bdy. The Flood Modeller will load up this file at the completion of the tabular results run. This file can also be loaded into an Flood Modeller datafile using the Flood Modeller Interface.

Initial Conditions

This option enables the user to write results from an existing simulation at a particular time to a pseudo-steady state file (extension '.zzs'). This file can then be used as initial conditions for a subsequent simulation using the same or similar model which begins at that time. You must remember to select the option "Use Initial Conditions From Initial Conditions File" on the File Tab of the 1D Scenario Data window and specify the external file you wish to utilise either by dragging a file from the Initial Conditions Section of the Project Panel or by using the browse button provided. Alternatively, one can import the zzs file into the initial conditions section of the datafile using the Flood Modeller Interface, and ensure that the aforementioned run option is not selected.

It should be noted that although the extension of the output file defaults to zzs, this does not mean that the results generated are steady-state results. This is merely a convenient way of using the results as a separate initial conditions file.

Output Options

Write Run Parameters

This an option which adds a summary of the run parameters used in the 1D model into the header of the output csv file.

Output Run Summary Header

Additional information such as the location of 1D output data file as well as the selected output time snaps shall be added to the header of the output csv file.

Estimated Panel Velocities

This feature can be activated by checking the Tabular-style output checkbox under the Output Options tab within the Tabular CSV window. This tool produces an ASCII file (extension .epv) which contains estimated local velocities in each panel at the selected cross sections (you must select Selected Data or Maxima and Minima before you can select Panel Velocities). This is calculated by determining conveyances for each panel, adjusting by the total section conveyance, and finally calculating average velocities per panel. The results in the epv file consist of flow, estimated velocity and wetted area for the full section and each panel.

Output Flood Extents

This feature can be activated by checking the Tabular-style output checkbox under the Output Options tab within the Tabular CSV window. This tool calculates the estimated left and right flood extents for each time step. The output is written into a *.wid file which contains the top width, level, left width and right width of the flood extent of each cross-section.

 

2D Results Tool Group

Time Series

The Time Series Plot Tool is used to view the time series plot of the 2D model results at a user specified point on the domain of the 2D model. The Time Series Plot tool can be accessed through the Time Series Plot button on the 2D Results toolbar.

Data Required for the Operation of the Tool

The following data has to be loaded into the list of layers on Flood Modeller in order for the Time Series Plot Tool to operate:

  1. A TIN (Triangular Irregular Network) file with 1D model results loaded on it OR a set of 2D Model Results (.2dm or .sup or xmdf.sup).

  2. A suitable background layer to enable you to locate points where you wish to review time series data, e.g. a ground grid, an aerial photo or map tile.

Basic Operation

After loading your data into the Flood Modeller interface, activate the tool by clicking the Time Series button in the 2D Results tool group (as shown above).

A new window is displayed over your map which lists the compatible datasets with time series data available and initially shows a blank time series chart. If you now click on the map you will see a square (usually red) marking the location where time series data are to be extracted. Then, on the time series plotting window, click in the box next to a dataset you wish to plot. A tick will appear in the box and the associated data should be added to the adjacent chart, as shown in the examples below:

Every subsequent click on your map view will refresh the chart with data from the revised location.

As for the case of the Cross Section Graph, there is a range of options displayed in a menu when you right click on the chart: The explanation of each option is provided below:

Copy Image - Copies the image in the viewer to the clipboard.

Export to Excel - Exports all chart data to Excel.

Change Line Colour - Changes the colour of the line showing various information on the plot

Save Image As - Saves the image as an .emf, .png, .gif, .jpeg, .tif or .bmp file and specifies the location the image should be saved to.

Page Setup - Gives access to the page setup window, allowing the user to edit the way the page will be printed.

Show Symbols - Adds a pattern to features for easier identification later.

Print - Opens a window allowing the user to start printing, select a printer and set various other related settings.

Show Point Values - When 'Show Point Values' is activated, holding the cursor above line showing the 1D/2D model results will provide information about the X, Y and Z co-ordinates of the nearest point on the status bar below the graph.

Un-zoom - Un-zooms to the previous zoom extent.

Undo All Zoom/Pan - Cancels all zooming and panning which has been carried out, returning chart to the original view.

Set Scale to Default - Sets the scale of zoom level to the default one (the one used at the start of using the Time Series Plot).

Plot Section


Overview

The purpose of this function is to produce a plot of cross section data from a user specified location. The tool requires you to define a polyline on your map to represent the cross section location. The tool will then read the data from the loaded GIS datasets underlying the polyline. The polyline can be loaded as a separate shapefile layer or drawn in Flood Modeller as a new layer (using the shapefile editor tool). Alternatively you can utilise the Measuring Tool to draw a (temporary) polyline as your cross section.

Data Required for the Operation of the Tool

The following data has to be loaded into the list of layers on Flood Modeller in order for the Cross Section Plot Tool to operate:

  1. A polyline shapefile which is either loaded as an external layer or drawn (with the shapefile editor) as a new layer. The tool expects only a single polyline in the specified file. However, in cases where there are several polyline features (representing cross sections) in the specified shapefile, then the cross section chart produced will show the information from all of these cross sections on the same chart. Alternatively the user can draw a 'temporary cross section' in the domain of the 1D or 2D model results using the Measuring Tool.

  2. A ground grid to extract the ground elevation information from;

  3. A TIN file with 1D results loaded or the 2D model results files to extract the water elevation information from (if necessary).

Basic Operation

To start the process, click the Plot Section button in the 2D Results tool group. A new window will appear giving you the option to either select any polyline shape file currently loaded in your map or to draw a new line to define your cross section. To use an existing shape file select it from the displayed list and click OK to continue. To draw a new line click the Draw button. This will activate an instance of the measure tool and you can click anywhere on the map to start drawing a line to define your cross section. Each subsequent click will add a new point to the line. Double click to complete the line and stop drawing.

After the shapefile has been selected, a Cross Section Plot window will appear; on the left hand side you need to select the grid file, the TIN file or one or all of the components of the 2D model results file you would like to see shown on your cross section plot. After this information has been selected, you will be able to see the resulting cross section plot, as shown by the example below.

The cross-section plot viewer is used to view cross-sections which have been loaded from a shape file. The cross-section is loaded with a default step of 20m. If you zoom in or out, the section step will change automatically.

The graph within the viewer can be manipulated in a number of ways. To zoom onto a specific area, the user should hold and drag the mouse over the relevant area. In order to pan, the user should hold and drag the middle mouse button. When the user right clicks on the cross section plot, a number of options will be made available:

Copy Image - Copies the image in the viewer to the clipboard.

Export to Excel - Exports the cross-section data, and water elevation data if present, to Excel.

Change Point Spacing - Changes the spacing of the chainage points on the cross section for which the information from the underlying grid or results file is extracted. In the next window the user needs to specify the value of the interval between these points in metres, i.e. the smaller the number entered, the more chainage points will be used for the interrogation of the underlying data.

Change Line Colour - Changes the colour of the cross section line

Save Image As - Saves the image as an .emf, .png, .gif, .jpeg, .tif or .bmp file and specifies the location the image should be saved to.

Show Symbols - Adds a pattern to the cross section line for easier identification

Page Setup - Gives access to the page setup window, allowing the user to edit how the page is setup for printing.

Print - Opens a window allowing the user to start printing as well as to select a printer and set various other related settings.

Show Point Values - When 'Show Point Values' is activated, holding the cursor above the cross section line will provide information about the X, Y and Z co-ordinates of the nearest point on the status bar below the graph.

Un-zoom - Un-zooms to the previous zoom extent.

Undo All Zoom/Pan - Cancels all zooming and panning which has been carried out, returning chart to the original view.

Set Scale to Default - Sets the scale of zoom level to the default one (the one used at the start of using the cross section tool).

There are the following buttons available on the cross-section plot form:

Clear All - Clears the Cross-section graph of all data.

Refresh - Updates the view of cross-section

 Flow Line


Overview

The Total Flow Crossing Line Tool is required for viewing a plot of the Flow component of the 2D Model Results at a particular cross section of the domain of the 2D model results. This cross section can be saved in a polyline shapefile or, alternatively, you can utilise the Measuring Tool to draw a cross section in the domain of the 2D model results.

The Data Required for the Operation of the Tool

The following data are required to be loaded in Flood Modeller for the Total Flow Crossing Line Tool to operate:

  1. 2D Model Results with Flow component;

  2. A shape file with a cross section consisting of two points drawn in the active area of the 2D Model Results. Alternatively you can draw a 'temporary' cross section using the Measuring Tool (this cross section has to be drawn immediately before activating the Total Flow Crossing Line Tool).

Basic Operation

Before activating the tool you must first load your 2D results data into the Flood Modeller viewport. The flow cross section line must then be defined either by loading an existing shapefile, drawing a new shapefile or using the Measuring Tool to create a temporary section. After loading your data proceed to activate the tool by clicking the Flow Line button in the 2D Results tool group. If you have not defined a section using the Measuring Tool then a new window is displayed over your map which lists the polyline shapefiles present within the viewport.

Select the shapefile that represents your cross section (this must only consist of two points and be drawn in the active area of the 2D Model) and then accept the selection by clicking the button OK.

If you have the Measuring Tool open with a measure line drawn on your map, then the tool will automatically use this instead of prompting for a shapefile.

Total Flow Crossing Line Plot then opens in a new window, consisting of an empty chart and a list compatible 2D results datasets present in the viewport. Select the 2D Model Result and Flow component files you would like to use (by clicking on the box adjacent to the list entry). The selected data parameter will then be calculated along your specified section line and these data are plotted in the tool chart, as shown by the example below:

It should be noted that this tool measures the amount of flow per cell. Therefore if the value of m3/s/m is considerably small then the tool might not be able to display the value and instead show a zero plot.

As for the case of the Cross Section Graph, there is a range of options displayed in a menu when you right click on the chart: The explanation of each option is provided below:

Copy Image - Copies the image in the viewer to the clipboard.

Export to Excel - Exports the cross-section data, and water elevation data if present to Excel.

Save Image As - Saves the image as an .emf, .png, .gif, .jpeg, .tif or .bmp file and specifies the location the image should be saved to.

Change Line Colour - Changes the colour of the line showing various information on the plot.

Page Setup - Gives access to the page setup window, allowing the user to edit the way the page will be printed.

Show Symbols - Adds a pattern to features for easier identification later.

Print - Opens a window allowing the user to start printing, select a printer and set various other related settings.

Show Point Values - When 'Show Point Values' is activated, holding the cursor above the line showing the 1D/2D model results the information about the X, Y and Z co-ordinates of the nearest point will be shown on the status bar below the graph.

Un-zoom - Un-zooms to the previous zoom extent.

Undo All Zoom/Pan - Undoes all zooming and panning which has been carried out, allowing the user to return to the original view.

Set Scale to Default - Sets the scale of zoom level to the default one (the one used at the start of using the Time Series Plot).

Flood Mapping

The 2D Flood Map button allows you to post process 2D results data to generate flood extent maps. These can be single snapshots within a time series, maximum flood extents or animated sequences of flooding. You can view flood extents overlaid on other GIS data, e.g. DEMs, aerial photos or Ordnance Survey tiles. The data generated by Flood Modeller can be exported for use in other applications, e.g. Google Earth and other GIS software or as images in reports.

Animations Tool Group

The animations tool group consists of a number of tools and buttons for controlling the animation of certain layers. It can be found in the Results tab. You have the option of viewing a Single Result (layer) or Multiple Results.

 

 

 

Compatible files that can be animated are 1D model results (added to a TIN file), 2D model results and TUFLOW results.