Project Panel

This panel contains the functionality to manipulate with and organize various Flood Modeller files for your 1D or 2D simulations. This panel has grouped all the Flood Modeller simulation files into the following categories: Networks, Event Data, Initial Conditions, Spatial Data, Associated Data and Simulations. These categories and functionality are described in more detail in the table below. The Project Panel is usually located in the upper left corner of the screen, but can be moved to a different location. The screenshot of the Project Panel is shown below.

The table below describes the categories of the files shown in the Project Panel and summaries how to add data to your project.

File type

/ Category

File Definition

How to load

1D network

Collections of connected 1D nodes saved with file extension “.dat”, (also known as Flood Modeller 1D model files)

  • Right click on the networks section of the project view and select “Add item”, then browse to your dat file

  • Click on the Add 1D Network button in the main toolbar (Home tab) then browse to dat file

  • Click on the New button in the main toolbar (Networks section of Home tab), define details of your new network and then go to the Model Build toolbar tab to start adding nodes to define a new network.

Event data

Subsets of your 1D networks that define variations to the default boundary data (as defined within the network), e.g. different historical flood events (flow time series), rainfall events (1 in 100yr storm) or tidal cycles (water level time series). These files have extension “.ied” and have a similar format to 1D network (dat) files

  • Right click on the event data section of the project view and select “Add item”, then browse to your ied file

  • Select the subset of nodes to add to your new event file from your active 1D network (in the map view or network or nodes tables). Right click on the network table and select the export function. You can then export the selected data to a new event file. You can then edit these data by making the new event file active in the interface).

Initial conditions

The default initial conditions settings for your 1D network (contained in the dat file) can be overridden by a separate initial conditions file. This is a text file that lists all network nodes and provides key parameter settings for each node. The extension can be “zzs” or “iic”.

  • Right click on the initial conditions section of the project view and select “Add item”, then browse to your zzc or iic file

  • Specify a simulation to output a snapshot file to be utilised as initial conditions. When the simulation is run this will be added to your project automatically

Spatial data

Both 1D and 2D simulations can utilise spatial data. 2D models are mainly defined by these data types, whereas 1D models utilise spatial data for flood mapping (in results post-processing). References to spatial data are defined in the associated model simulation files. You can use this section of the project to store references to the spatial datasets you are using.

  • You can view these data in the Flood Modeller map view by adding them to the layers window.

  • However, in some cases, you may not wish to visualise these spatial datasets, but still associate them to your project. In this case right click on the spatial data section of the project view and select “Add item”, then browse to your spatial dataset

  • You can drag GIS layers from the Layers panel to the Spatial Data section of the Project panel  (and vice versa).

Associated files

This section of the project can store any files. This enables you to add references to files that are not part of your models but may be directly relevant to your project, e.g. photos, reports, presentations, etc.

  • Right click on the associated data section of the project view and select “Add item”, then browse to your file.

Simulations

All models types are defined by a simulation file. If you are investigating different scenarios then each one will require a simulation file that references all input data and details your associated simulation settings. 1D simulation files are text format with extension “ief”. 2D simulations are xml format (“.xml”). Linked models will use a combination of these files.

  • Right click on the simulations section of the project view and select “Add item”, then browse to an existing ief or 2D xml file.

  • Right click on the simulations section of the project view and select “New 1D simulation”. The 1D model definition window will be displayed enabling you to define a new ief file.

  • Right click on the simulations section of the project view and select “New 2D simulation”. The 2D model definition window will be displayed enabling you to define a new xml file. You can also add a reference to a 1D simulation file here for linked models.

  • Right click on the simulations section of the project view and slect "New 1D Quality Simulation". The 1D water quality model definition window will be displayed enabling you to define a new qef file.

  • Double-click on an existing simulation file. The relevant simulation definition window will be displayed with the selected file loaded. You can then define revised settings and use the Save As option to create a new simulation, which will then be added to your project automatically.

  • New 1D, 2D or linked simulations can also be defined by clicking the relevant new simulation button in the simulations tab of the main toolbar.

Right-click menus

There are right-click menus for the category titles and the files loaded into each category which aim is to aid the user with loading/unloading files from a certain category and also carry out specific operations with this type of files. These right-click menus are described in more detail below.

The menu items when a category title has been right-clicked (see the screenshot below) are Add Item and Remove All.

The Add Item menu allows you to load new files of the respective type(s) into the Project Panel (and Flood Modeller).

The Remove All menu allows you to unload all items from the category.

The menu items when a file in a category has been right-clicked differ depending on the category. These are described below.

Menu items available for all categories

Remove – The Remove item unloads the file from the project, as a result this file will no longer be displayed in the View Map and its data will not be available for use 

Properties - The Properties item opens a window with file properties containing file name, description and file path.

Networks Category Menu Items

View menu item includes the following sub-items: Show Nodes, Channel Bitmaps, Non-channel Bitmaps, Show Labels, Show Links, and Allow Overlaps. These are described below.

Set Active – if several 1D Network files have been loaded into the Project Panel then this button allows you to set the network (onto which you right-clicked to see the right-click menu) as active. If the network is active then you have access to the functionality of the rest of the View menu items and Export menu items for this network.

Show Nodes - The Show Nodes item, when clicked, enables you to see the location of nodes in the Map View.

Channel Bitmaps – The Channel Bitmaps item replaces the black dots on the Map View with a channel icon.

Non-channel Bitmaps – The Non-Channel Bitmap item replaces the marked location on the Map View with an icon indication which type of a node it is.

Show Labels – The Show Labels item displays the label of the node in the Map View.

Show Links – The Show Links item displays the connection between the nodes in the Map View.

Allow Overlaps – The Allow Overlaps option will display all nodes of a network in the map view, including those which overlap each other.

Export menu item includes the following sub-items: Nodes As Shapefile, Links As Shapefile. These are described below.

Nodes As Shapefile - The Export Nodes As Shapefile item allows you to save the nodes only as a new shapefile. A new window will open where you will be able to type the file name and select file destination location.

Links As Shapefile - The Export Links As Shapefile item allows you to save the links between nodes only as a new shapefile. A new window will open where you will be able to type the file name and select the destination location of the file.

Zoom to Network Menu Item – The Zoom to Network Menu Item displays the selected network in the Map View to its maximum extend, showing all nodes and links.

Spatial Data Menu Items

In addition to Add Item and Remove, this menu contains:

Add to Map – The Add to Map item displays the content of the selected file in the Map View.

Associated Data Menu Items

In addition to Add Item and Remove, this menu contains:

Open – The Open item opens the selected associated data file. This can also be achieved by double-clicking on the item.

Simulations Menu Items

In addition to Add Item and Remove, this menu contains:

Set Active – Sets the selected simulation (ief) file to active. This means the results associated to this simulation will be accessible from the 1D results plotting tools provided in the map and Project panel right-click menus.

A 1D network will likely be used for multiple simulations, with each one using different boundary data (event files), e.g. to investigate the effects of different storm intensities. When a network is active in the map view you can access simulation results associated to each node via the map and Network panel right-click menus. By default these tools will access results associated to the simulation marked as active (this will be displayed in bold text in the Project panel).

You can set a different simulation to be active by right-clicking on the file in the Project panel and selecting the Set Active option. If the selected result is associated to the currently active network then you will then be able to select nodes in the map or Network panel and plot the data associated to this simulation for these nodes. If the selected simulation relates to a different network then this network will become active and be loaded into the map and Network panel. If the associated network is not part of your project then it will be first added to the project panel and then be made active.

New 1D Simulation – allows you to create a new 1D simulation file (ief file). A window will open allowing you to type file name and choose the file location. Once saved a new window will appear with options to set up the simulations parameters (See Open Menu Item).

New 1D Quality Simulation - allows you to create a new water quality simulation file (qef file). A window will open allowing you to type file name and choose the file location. Once saved a new window will appear with options to set up the simulation parameters (See Open Menu Item).

New 2D Simulation - allows you to create a new 2D simulation file (xml file). A window will open allowing you to type file name and choose the file location. Once saved a new window will appear with options to set up the simulation parameters.

Open – The Open item opens a new window with simulation options for the selected file. For 1D simulations you can set File, Time, Snapshot, CES, Low Flow, Additional Output and Backward Parameters, save changes and/or run the simulation (interface for 1D quality simulations is also similar to this) .For 2D simulations you are prompted to set General 2D settings and specify 2D Domains. Once defined you can save the model and/or run the simulation or close the window.

Copy – Creates a copy of the selected simulation file and adds it to your project. The function will prompt you to provide a new name and save location for the copied file. This function enables you to quickly create multiple instances of a simulation file, which might contain many complex settings (that would be time consuming to completely recreate for each instance). You can then quickly edit each copied file to meet requirements, e.g. edit the boundary event data specified to represent different storm events.

View Result – Prompts you to select which output datasets from a 2D simulation you wish to visualise in your map view. This is the same process as loading 2D model results into the map using the Add GIS Data button, but without the need to browse to your files first.

Load GIS Data – Reads the GIS format datasets referenced in your 2D simulation file and adds these layers to your map view.